https://infracost.io logo
#help
Title
# help
p

powerful-kangaroo-4585

09/11/2023, 2:49 PM
Hi all - does anyone know why infracost is ignoring my currency settings?: .config\infracost\configuration.yml
Copy code
version: "0.1"
currency: "GBP"
w

white-airport-8778

09/11/2023, 2:58 PM
What CLI version are you using? This works ok for me running locally, and I don’t have the
INFRACOST_CURRENCY
env var set either so the config file is used:
Copy code
$ infracost configure set currency GBP

$ cat ~/.config/infracost/configuration.yml
version: "0.1"
currency: GBP
p

powerful-kangaroo-4585

09/18/2023, 10:21 AM
Thank you for your reply: I am using the github pull request feature and it ignores all config. No idea how to fix it.
w

white-airport-8778

09/18/2023, 10:27 AM
@powerful-kangaroo-4585 which CI/CD integration are you using? For GitHub Actions, you should set the
INFRACOST_CURRENCY
env var. For GitHub App, you should set the same env var during the Org Settings > Integrations > GitHub App wizard. Did you try any of those options?
p

powerful-kangaroo-4585

09/18/2023, 11:15 AM
Hi - now reporting $0 cost for Azure App Service S0 - I think something is very wrong - there don't seem to be any logs so I think this trial is over. Thank you!
l

little-author-61621

09/18/2023, 2:02 PM
Hi @powerful-kangaroo-4585, are you able to provide the Terraform code you’re using for this resource? I’m unable to find prices on the Azure website for S0.
p

powerful-kangaroo-4585

09/18/2023, 2:26 PM
Sorry the plan SKU was s1 - but still is giving 0$
Copy code
resource "azurerm_service_plan" "appserviceplan" {
  name                = "asp"
  resource_group_name = azurerm_resource_group.my_web_app_rg.name
  location            = azurerm_resource_group.my_web_app_rg.location
  os_type             = "Windows"
  sku_name            = "S1"

}
location is UK South
l

little-author-61621

09/18/2023, 2:35 PM
Thanks, let me dig into this a little more.
@powerful-kangaroo-4585 can you please DM me your Infracost Cloud Org ID? It should be visible in the Org Settings page.
Okay, I think these 2 things should fix it: 1. Remove the config file from Org Settings > Default repo config file 2. Got to Org Settings > Integrations > GitHub.com & Enterprise Cloud * Click Next * For ‘Do you need additional environment variables?’ Click Yes. * Add
INFRACOST_CURRENCY
,
GBP
p

powerful-kangaroo-4585

09/19/2023, 10:18 AM
Not sure if this is progress - I changed the app service type and the environment var but still reporting in $$$ - I get GBP in the console when I run the tool using exe or docker etc with the environment variable set. Can't thank you enough for the help @little-author-61621.
l

little-author-61621

09/19/2023, 9:37 PM
@powerful-kangaroo-4585 awesome! I’ve just checked your account and it looks like the env var was named
INFRACOST_CURRENCY,
instead of
INFRACOST_CURRENCY
. I’ve updated that for you now - can you have a look and see if it’s working for you?
p

powerful-kangaroo-4585

09/22/2023, 1:37 PM
Just checked and it does appear to be working in GBP/£ Sterling. Thank you.
l

little-author-61621

09/22/2023, 5:17 PM
Awesome, thanks for confirming!